Kirjoittaja Aihe: Arduino Nanon com-porttiasetukset  (Luettu 1681 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa J Piira

  • Eksoplaneetta
  • ***
  • Viestejä: 499
Arduino Nanon com-porttiasetukset
« : 23-02-2021, 20:43:14 »
Kokeilin testata Arduino fokuseria Amazonista tilatulla Nano:lla. Mutta sille ei koneeseen tullut com-porttia. Yritin muuttaa laitehallinnan kautta, mutta en oikein tiedä mitä olisi pitänyt valita. Ensin portiksi tuli com8  Arduino duo. Seuraavalla kokeiliulla nuo mitkä kuvissa näkyy, mutta ei arduino ide saanut kokeilu koodia lähetetyksi. Olisiko vihjeitä? Niin tuossa  Nano-laatikossa lukee Az-Delivery Nano V3 mit FTDI
Atik 383L+
- Jukka -

Poissa GaryP

  • Rinnakkaisuniversumi
  • *****
  • Viestejä: 1714
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #1 : 23-02-2021, 22:37:02 »
Onko sulla se konkka kiinni kun yrität? Jos on niin ota pois.

Kari
Kari Pulkkinen
Espoo, Finland

Harrastus uudelleen lämpiämässä...

Poissa GaryP

  • Rinnakkaisuniversumi
  • *****
  • Viestejä: 1714
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #2 : 23-02-2021, 22:40:09 »
Mitä laitehallintaan porttien kohdalle tarkalleen ottaen ilmestyy kun liität Nanon? Vai mitään?
Tuleeko tunnistamaton laite toiseen väliin?

Kari


Kari Pulkkinen
Espoo, Finland

Harrastus uudelleen lämpiämässä...

Poissa J Piira

  • Eksoplaneetta
  • ***
  • Viestejä: 499
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #3 : 24-02-2021, 07:47:33 »
Tuota olen nyt kokeillut pelkällä arduino nanolla ilman mitään kytkentää. Tulee kuvan mukaisesti muuna laitteena näkyviin. Noissa edellisissä on kuvia siitä kun yritin päivittää ohjainta. Sinne tulikin com8, mutta ei se päivitys varmaankaan ihan oikein mennyt kun ei toiminut.  Siinä edellisessä toimivassa mallissa se konkka pitää olla siinä vaiheessa kun käyttää moonlite fokuserina muuten ei löydä.


Ei näytä löytävän tuota nanoa. Uno kyllä näkyy ja toimii.
« Viimeksi muokattu: 24-02-2021, 10:46:32 kirjoittanut J Piira »
Atik 383L+
- Jukka -

Poissa J Piira

  • Eksoplaneetta
  • ***
  • Viestejä: 499
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #4 : 25-02-2021, 08:46:40 »
Tuolla virheilmoituksella, joka tämän ketjun ensimmäisellä sivulla on löytyy googlettamalla arduinon palsta, jossa samasta ongelmasta aika paljon kyselyjä. En niistä oikein saanut selvää mistä tämä oikeasti johtuu. Kokeilin myös AZ-deliveryn ohjetta com portin asentamisesta, mutta en silläkään saanut. Tilasin aidon Arduino Nanon ja kokeilen sillä toimiiko se minun taidoillani.
Atik 383L+
- Jukka -

Poissa J Piira

  • Eksoplaneetta
  • ***
  • Viestejä: 499
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #5 : 25-02-2021, 19:38:23 »
Kyllä aidolla Arduino Nanolla kaikki toimii ihan  hienosti.
Atik 383L+
- Jukka -

Poissa GaryP

  • Rinnakkaisuniversumi
  • *****
  • Viestejä: 1714
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #6 : 25-02-2021, 20:33:21 »
Mä olen ostanut noita Nano klooneja ainakin viisi kappaletta (mennyt jo laskuissa sekaisin kun näitä arduino variaatiot/ESP8266/ESP32 on yhteensä ainakin 30) eikä kahta Nanoa ole ollut samanlaista, ja kaikki ovat toimineet.
Suosittelen vielä tyhmää testiä, kokeile toisessa koneessa.

Kari

Kari Pulkkinen
Espoo, Finland

Harrastus uudelleen lämpiämässä...

Poissa J Piira

  • Eksoplaneetta
  • ***
  • Viestejä: 499
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #7 : 25-02-2021, 20:55:36 »
Kokeilin Windows 7 koneessa ja sama juttu oli sielläkin. Onko sinulla toiminut ihan suoraan ilman eri ajureiden lataamista. Pitää noita vielä jossain vaiheessa yritellä ihan mielenkiinnosta.
Atik 383L+
- Jukka -

Poissa Pappis

  • Rinnakkaisuniversumi
  • *****
  • Viestejä: 1213
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #8 : 25-02-2021, 22:00:50 »
Onko BIOS-puolella COM-asetukset ok?

Poissa J Piira

  • Eksoplaneetta
  • ***
  • Viestejä: 499
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #9 : 25-02-2021, 22:09:50 »
Jotainhan siellä varmaankin on pielessä, mutta minun tietouteni ei oikein riitä tuon asian tutkimiseen.
Atik 383L+
- Jukka -

Poissa GaryP

  • Rinnakkaisuniversumi
  • *****
  • Viestejä: 1714
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #10 : 25-02-2021, 22:35:09 »
Onko BIOS-puolella COM-asetukset ok?

Bios ei vaikuta erilliseen USB-com-porttiin.

Koitapas ohjeita täältä: https://learn.sparkfun.com/tutorials/how-to-install-ftdi-drivers/all

EDIT. Piiri on FT232RL

Kari
Kari Pulkkinen
Espoo, Finland

Harrastus uudelleen lämpiämässä...

Poissa J Piira

  • Eksoplaneetta
  • ***
  • Viestejä: 499
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #11 : 26-02-2021, 07:34:23 »
Eilen kokeilin taas noita ohjainten ja com-portin asentelua, mutta en saanut uploaduksi tuolla kopio arduinolla. Nyt kun kokeilin, niin com portti löytyi ja otti koodin vastaan ihan ok valintana piti olla ATmega 328P (old Bootloeder). Olisiko niin, että piti uudelleen käynnistää ja se oli unohtunut.  Kiitoksia Karille ja kaikille muillekin.
Atik 383L+
- Jukka -

Poissa GaryP

  • Rinnakkaisuniversumi
  • *****
  • Viestejä: 1714
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #12 : 26-02-2021, 08:19:55 »
Aha, siinä onkin CH340 eikä FTDI:n piiri.

Alkuperäisessä viestissä oli "Nano-laatikossa lukee Az-Delivery Nano V3 mit FTDI", joten myyjä
ei ole itsekään sitten tiennyt tuotteestaan. Ja vielä vanhalla bootloaderilla, olisko myynyt
halpaa kiina-kamaa mainostamansa tilalla?

Kari
Kari Pulkkinen
Espoo, Finland

Harrastus uudelleen lämpiämässä...

Poissa J Piira

  • Eksoplaneetta
  • ***
  • Viestejä: 499
Vs: Arduino Nanon com-porttiasetukset
« Vastaus #13 : 26-02-2021, 08:59:23 »
Joo tuollaisessa laatikossa ne tulivat.
Atik 383L+
- Jukka -