Kirjoittaja Aihe: ASI294MC Flättiongelma ja vähän muutakin  (Luettu 1586 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa Jommeli

  • Eksoplaneetta
  • ***
  • Viestejä: 109
ASI294MC Flättiongelma ja vähän muutakin
« : 08-11-2020, 14:58:45 »
Moi!

Pienoisia ongelmia tuon ASI294MC Pro kameran kanssa. Perjantai-iltana sain tilaisuuden kokeilla miten Optolongin L-eXtreme filtteri toimisi ko. kamerassa (Filtterin toimitusta sai odottaa lähes kaksi kuukautta). Ajateltu kohde (NGC6914) meni vähän sivuun mutta se oli oma moka ja kysymykseni liittyykin flätteihin.

Oheisessa kuvassa näette miltä master-flätti näyttää mustavalkoisena (vasemmalla) ja histogrammi kuvan alapuolella. Flätti debayeroituna väreiksi on oikealla ylhäällä ja se näyttää kyllä todella omituiselta. Oikealla alhaalla on kalibroituna varsinainen tähtikuva, josta näkee että kalibrointi on jättänyt pölytuhnut kuvaan ja kuva on muutenkin omituista "värimössöä".   :huh:

Koko kalibrointiprosessi on tehty Pixinsightin Weighted Batch Preprocessin skriptillä. Olen yrittänyt tehdä sen erilaisilla parametreilla ja jopa kalibroinut kuvat ImageCalibration-prosessilla mutta tulos on aina vähintään yhtä surkea. Näyttää myös siltä että darkki ei ole toiminut täydellisesti koska kuvassa näkyy amp glowta oikeassa yläkulmassa.

Ihmettelen myös miksi kuvien rekisteröinti ei onnistu kyseisellä skriptillä. Välillä antaa virhettä että rekisteröinti ei onnistu ja välillä ei anna mitään virhettä mutta kuvat eivät ole kohdistuneet lainkaan. StarAligment-prosessi kohdistaa kuvat kuitenkin ihan ok mutta miksi tuo WBPP-skripti ei toimi tuolta osin?

Siis aika kuutamolla olen nyt että mikä tässä mättää, joten kaikki apu olisi todella kiitollisuudella vastaanotettua. Annan mielelläni lisäinfoa otetusta datasta ja muusta prosessiin liittyvästä.

T:JormaY
« Viimeksi muokattu: 08-11-2020, 16:25:50 kirjoittanut Jommeli »
GSO 150/750 Newton, Celestron CG-5/GT, Skywatcher Startravel 80;
ZWO ASI294MC Pro, Orion Starshoot g3, Microsoft Lifecam Cinema

Poissa Jommeli

  • Eksoplaneetta
  • ***
  • Viestejä: 109
Vs: ASI294MC Flättiongelma ja vähän muutakin
« Vastaus #1 : 08-11-2020, 16:11:06 »
Jotain mulla on tossa PI:n asetuksissa pielessä koska Siril ja DSS tekee ihan ok jälkeä integroituun kuvaan. En vaan keksi että mitä asetuksia tossa PI:ssä voisi olla pielessä.
Tämä sama ongelma on ollut käytännössä koko syksyn PI:ssä. Käytin aiemmin järkkäriä kuvaamiseen mutta sama asia kai toi ASI:n OSC sinällään on?
Ohessa kuva DSS:llä stäkätystä kuvasta (tai sanoisinko rajatusta sellaisesta).

Olettaisin että foorumilta löytyy henkilöitä jotka kuvaa tuolla ASI:n kameralla ja prosessoi PI:llä eli minkälaisilla konfiguraatioilla PI:ssä kalibrointi/Preprosessointi pitäisi tehdä?
GSO 150/750 Newton, Celestron CG-5/GT, Skywatcher Startravel 80;
ZWO ASI294MC Pro, Orion Starshoot g3, Microsoft Lifecam Cinema

Poissa Jommeli

  • Eksoplaneetta
  • ***
  • Viestejä: 109
Vs: ASI294MC Flättiongelma ja vähän muutakin
« Vastaus #2 : 08-11-2020, 18:42:19 »
Tässäkin näkee melko selvän eron torstain 5.11. Andromedan kuvassa (valotukset 80x30s). Vasemmalla PI:llä kalibroitu ja oikealla DSS:llä kalibroitu kuva. Täysin samat alkuprosessit (DBE, Photometric color calibration, EZ soft stretch, ACDNR ja HDRMultiscale Transform) ajettu molempiin PI:llä paitsi PI:llä kalibroitua kuvaa piti cropata jonkin verran koska reunat olivat melko "suttuiset". Tässä ei flätit kuitenkaan "tuhrineet" master-valotusta. Suotimena oli IDAS LPS D1.
Alan pitämään noista DSS:n ja Sirilin kalibrointien vaivattomuudesta verrattuna PI:hin mutta pitäishän tolla PI:llä saada parempaa jälkeä kuin Open source softilla  :grin:
GSO 150/750 Newton, Celestron CG-5/GT, Skywatcher Startravel 80;
ZWO ASI294MC Pro, Orion Starshoot g3, Microsoft Lifecam Cinema

Poissa Jommeli

  • Eksoplaneetta
  • ***
  • Viestejä: 109
Vs: ASI294MC Flättiongelma ja vähän muutakin
« Vastaus #3 : 10-11-2020, 07:32:28 »
Lisäinfoa sen verran että tämä ei sittenkään näyttäisi olevan flättiongelma vaan tuo ero syntyy varsinaisten valotusten (lightit) kalibroinnissa.
Tein PI:llä, Sirilillä ja DSS:llä kaikilla master-flätit ja ne näyttivät suht identtisiltä. Nyt pitää yrittää ratkaista mikä tuossa lightien kalibroinnissa poikkeaa.

Vielä sen verran lisäinfoa että tein PI:llä lightien kalibroinnin pelkällä darkilla ja lopputulos oli paras mitä tähän asti olen saanut aikaan. Siis flätillä kalibrointi aiheuttaa ongelmia mutta en tosiaankaan tiedä onko vika flätissä vai itse kalibrointiprosessin parametreissa.  :rolleyes:
Oheiselle kuvalle on tehty pelkkä DBE ja PhotometricColorCalibration.

T:Jorma
« Viimeksi muokattu: 10-11-2020, 08:44:38 kirjoittanut Jommeli »
GSO 150/750 Newton, Celestron CG-5/GT, Skywatcher Startravel 80;
ZWO ASI294MC Pro, Orion Starshoot g3, Microsoft Lifecam Cinema

Poissa Jommeli

  • Eksoplaneetta
  • ***
  • Viestejä: 109
Vs: ASI294MC Flättiongelma ja vähän muutakin
« Vastaus #4 : 11-11-2020, 14:03:56 »

Ihmettelen myös miksi kuvien rekisteröinti ei onnistu kyseisellä skriptillä. Välillä antaa virhettä että rekisteröinti ei onnistu ja välillä ei anna mitään virhettä mutta kuvat eivät ole kohdistuneet lainkaan. StarAligment-prosessi kohdistaa kuvat kuitenkin ihan ok mutta miksi tuo WBPP-skripti ei toimi tuolta osin?


Tämä rekisteröintiongelma näytti olevan yleisempikin ongelma tuossa WBPP-skriptissä. No sain sen ratkaistua kun otin "use triangle similarity"-täpän pois päältä (kuva ohessa).

Flättiongelma ei ole ratkennut vieläkään eikä täältä foorumiltakaan ole näyttänyt toistaiseksi apuja löytyvän.
GSO 150/750 Newton, Celestron CG-5/GT, Skywatcher Startravel 80;
ZWO ASI294MC Pro, Orion Starshoot g3, Microsoft Lifecam Cinema

Poissa LauriT

  • Periodinen komeetta
  • **
  • Viestejä: 33
Vs: ASI294MC Flättiongelma ja vähän muutakin
« Vastaus #5 : 12-11-2020, 17:48:02 »
Itselläni oli viime kaudella jatkuvasti jotain häikkää Pix:ssä korjauskuviin liittyen ja laiskana en jaksanut syventyä asiaan sen enempää - ja kun Pix:ssä sylttäsi, niin DSS hoiti aina homman. Mutta tälle kaudelle otin 30 päivän ilmaisen kokeilujakson Astro Pixel Prosessor -ohjelmasta ja se on kyllä pelannut kuin entivanhanen junan vessa. En ole vielä syventynyt ohjelman hienouksiin, mutta default-asetuksilla tuottaa hyvännäköistä kuvaa.

Poissa Riku Talvio

  • Meteoroidi
  • *
  • Viestejä: 8
Vs: ASI294MC Flättiongelma ja vähän muutakin
« Vastaus #6 : 12-11-2020, 18:54:48 »
Ylikorjaus näyttää olevan ongelmana.
Tästä saattaa löytyä ratkaisu: https://youtu.be/uVx07KIdDMU Samalta tekijältä löytyy varmaan kymmenen tuntia jaarittelua aiheesta, ja sen vierestä.

Jos laitat tarvittavat ruudut jakoon, voisin itsekin koittaa kalibrointia. Sama kamera löytyy, ja teen aina manuaalisesti. WBPP on syöpä, joka pitäisi poistaa.

Poissa Jommeli

  • Eksoplaneetta
  • ***
  • Viestejä: 109
Vs: ASI294MC Flättiongelma ja vähän muutakin
« Vastaus #7 : 13-11-2020, 16:13:03 »
Ylikorjaus näyttää olevan ongelmana.
Tästä saattaa löytyä ratkaisu: https://youtu.be/uVx07KIdDMU Samalta tekijältä löytyy varmaan kymmenen tuntia jaarittelua aiheesta, ja sen vierestä.

Jos laitat tarvittavat ruudut jakoon, voisin itsekin koittaa kalibrointia. Sama kamera löytyy, ja teen aina manuaalisesti. WBPP on syöpä, joka pitäisi poistaa.

Itsekin tuumin että flätti ylikorjaa mutta enpä edes ajatellut että syy voisi löytyä darkeista. Vertasin flättidarkkeja ja normidarkkeja toisiinsa ja huomasin tuon saman eroavaisuuden kuin tuossa videolla. Parhaillaan menee darkit uusiksi joten katsotaan auttaako mitään.

Toinen asia jota epäilin oli tuo flättien valotusaika josta tuossa videollakin mainitaan. Niille en voi enää tuon kyseisen session osalta tehdä mitään mutta eilen meni tilaukseen himmennyksellä varustettu "valotaulu" josko sen avulla saisi tuleviin sessioihin hieman pitemmän valotuksen omaavat flätit.

Kiitoksia vinkeistä, katsotaan tuleeko parannusta asiaan.
GSO 150/750 Newton, Celestron CG-5/GT, Skywatcher Startravel 80;
ZWO ASI294MC Pro, Orion Starshoot g3, Microsoft Lifecam Cinema

Poissa Jommeli

  • Eksoplaneetta
  • ***
  • Viestejä: 109
Vs: ASI294MC Flättiongelma ja vähän muutakin
« Vastaus #8 : 13-11-2020, 17:00:10 »
Ihmeellinen on tämä tähtikuvauksen maailma.
Tein uudet Darkit ja tässä lopputulos. Ei mitään täydellistä mutta aiempi ongelma katosi. Kokeiluasteellahan tässä ollaan vasta uuden kameran, N.I.N.A:n, Focuserin yms kanssa.

« Viimeksi muokattu: 14-11-2020, 13:07:31 kirjoittanut Jommeli »
GSO 150/750 Newton, Celestron CG-5/GT, Skywatcher Startravel 80;
ZWO ASI294MC Pro, Orion Starshoot g3, Microsoft Lifecam Cinema